blob: dca929b574560a61e822e776561f434e47058395 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Web-based Traffic and Security Network Traffic Monitoring"
2DESCRIPTION = "ntopng is a web-based network traffic monitoring application \
3released under GPLv3. It is the new incarnation of the original \
4ntop written in 1998, and now revamped in terms of performance, \
5usability, and features."
6
7SECTION = "console/network"
8
9DEPENDS = "curl libmaxminddb libpcap lua mariadb ndpi json-c rrdtool zeromq"
10RDEPENDS:${PN} = "bash redis"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "GPL-3.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14SRCREV = "d3ce78948e8d81dc1e2c5298ce556f9f2247aac1"
15SRC_URI = "git://github.com/ntop/ntopng.git;protocol=https;branch=5.2-stable \
16 file://0001-configure.ac.in-fix-configure-error.patch \
17 file://0001-configure.ac.in-fix-host-contamination.patch \
18 file://0001-Makefile.in-don-t-use-the-internal-lua.patch \
19 file://0001-autogen.sh-generate-configure.ac-only.patch \
20 file://0001-configure.ac.in-not-check-clang-on-host.patch \
21 file://0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch \
22 file://ntopng.service \
23 "
24
25S = "${WORKDIR}/git"
26
27# don't use the lua under thirdparty as it supports cross compiling badly
28export LUA_LIB = "${STAGING_LIBDIR}/liblua.a"
29
30LDFLAGS:append:mipsarch = " -latomic"
31LDFLAGS:append:powerpc = " -latomic"
32LDFLAGS:append:riscv32 = " -latomic"
33inherit autotools-brokensep gettext pkgconfig systemd
34
35do_install:append() {
36 install -d ${D}${systemd_unitdir}/system/
37 install -m 0644 ${WORKDIR}/ntopng.service ${D}${systemd_unitdir}/system
38}
39
40FILES:${PN} += "\
41 ${systemd_unitdir}/system/ntopng.service"
42
43FILES:${PN}-doc += "\
44 /usr/man/man8/ntopng.8"
45
46do_configure:prepend() {
47 ${S}/autogen.sh
48}
49
50SYSTEMD_SERVICE:${PN} = "ntopng.service"