blob: 7bca24cc0a0fbf4f9aa65d7a291a1844feb45219 [file] [log] [blame]
Brad Bishop36a3e3e2019-10-02 13:29:27 -04001SUMMARY = "A small tool to read/write memory"
Brad Bishop00ab2372019-10-14 11:06:18 -04002DESCRIPTION = "rwmem is a small tool for reading and writing device registers. \
3rwmem supports two modes: mmap mode and i2c mode. \
4\
5In mmap mode rwmem accesses a file by memory mapping it. \
6Using /dev/mem as the memory mapped file makes rwmem access memory and \
7can thus be used to access devices which have memory mapped registers. \
8\
9In i2c mode rwmem accesses an i2c peripheral by sending i2c messages to it."
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "GPL-2.0-or-later"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040012LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
13
14DEPENDS += "python3 python3-pybind11"
15
16PV .= "+git${SRCPV}"
17
Brad Bishope42b3e32020-01-15 22:08:42 -050018SRCREV_rwmem = "3ec3e421211b58e766651c2e3a3a21acf14a1906"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040019SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109"
20
21SRCREV_FORMAT = "rwmem_inih"
22
23SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +000024 git://github.com/tomba/rwmem.git;protocol=https;name=rwmem;branch=master \
Brad Bishop36a3e3e2019-10-02 13:29:27 -040025 git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \
26"
27
28S = "${WORKDIR}/git"
29
30inherit cmake pkgconfig
31
32do_install() {
33 install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem
34 install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a
35}