blob: 8fad04e365ea3c6161f036367680d87a9d7fb376 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "Whetstone benchmark is a synthetic benchmark for evaluating the performance of computers"
2SUMMARY = "CPU benchmark to measure floating point performance"
3
4LICENSE = "PD"
5LIC_FILES_CHKSUM ="file://${WORKDIR}/whetstone.c;beginline=1;endline=52;md5=c795edc15e7e1d92ca8f88ad718449f5"
6
7SRC_URI = "http://www.netlib.org/benchmark/whetstone.c"
8SRC_URI[md5sum] = "d8eb2cd7104bb5a12d614ac6d3f1f9fb"
9SRC_URI[sha256sum] = "333e4ceca042c146f63eec605573d16ae8b07166cbc44a17bec1ea97c6f1efbf"
10
11S = "${WORKDIR}"
12
13do_compile () {
14 ${CC} ${CFLAGS} ${LDFLAGS} -Ofast -o whetstone whetstone.c -lm
15}
16
17do_install () {
18 install -Dm 0755 whetstone ${D}${bindir}/whetstone
19}
20