blob: 8a27cf9b90f990d6216a5a879a9f68a039d7f34b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# TODO: include debian's mtp-tools man page (needs xsltproc-native and
2# docbook-xsl-native, or we pregenerate it), add support for doxygen
3# generation fully with -natives
4DESCRIPTION = "libmtp is an Initiator implementation of the Media Transfer \
5Protocol (MTP) in the form of a library suitable primarily for POSIX \
6compliant operating systems"
7SUMMARY = "libmtp is an Initiator implementation of the Media Transfer Protocol (MTP)"
8HOMEPAGE = "http://libmtp.sourceforge.net/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "LGPL-2.1-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010LIC_FILES_CHKSUM = "\
11 file://COPYING;md5=0448d3676bc0de00406af227d341a4d1 \
12 file://src/ptp.c;beginline=3;endline=22;md5=303cc4422fd549ef8689aded20434a9a \
13 file://examples/albums.c;beginline=5;endline=21;md5=84f4e55dfec49e898b7f68a828c15620 \
14"
15
16BBCLASSEXTEND = "native"
17
18DEPENDS = "libusb1 gettext-native"
Patrick Williams213cb262021-08-07 19:21:33 -050019DEPENDS:append:class-target = " ${BPN}-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
Patrick Williams213cb262021-08-07 19:21:33 -050022SRC_URI:append:class-target = " file://0001-Use-native-mtp-hotplug.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050024SRC_URI[md5sum] = "7915496daa3f4ea3e095f0161f83d4d4"
25SRC_URI[sha256sum] = "7280fe50c044c818a06667f45eabca884deab3193caa8682e0b581e847a281f0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27inherit autotools pkgconfig lib_package
28
29EXTRA_OECONF += " \
30 --disable-rpath \
31 --with-udev=${nonarch_base_libdir}/udev \
32"
33
34PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}"
35PACKAGECONFIG[doxygen] = "--enable-doxygen,--disable-doxygen"
36PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile"
37PACKAGECONFIG[mtpz] = "--enable-mtpz,--disable-mtpz,libgcrypt"
38
39PACKAGES =+ "${BPN}-common ${BPN}-runtime"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041RDEPENDS:${BPN} += "libmtp-common"
42RRECOMMENDS:${BPN} += "libmtp-runtime ${PN}-bin"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043
Patrick Williams213cb262021-08-07 19:21:33 -050044FILES:${BPN}-common = "${nonarch_base_libdir}/udev/rules.d/*"
45SUMMARY:${BPN}-common = "The udev rules file for MTP devices"
Andrew Geissler82c905d2020-04-13 13:39:40 -050046
Patrick Williams213cb262021-08-07 19:21:33 -050047FILES:${BPN}-runtime = "${nonarch_base_libdir}/udev/mtp-probe"
48RDEPENDS:${BPN}-runtime = "libmtp-common"
49SUMMARY:${BPN}-runtime = "mtp-probe, used for the MTP udev rules"
50DESCRIPTION:${BPN}-runtime = "This package provides mtp-probe, a program to probe newly connected device interfaces from userspace to determine if they are MTP devices, used for udev rules."