blob: 2fa24b29b3f6fd98dbbb2fdc0f730ab789ee30d6 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 file://don-t-run-code-while-configuring-package.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 "
Brad Bishop868407c2019-11-04 13:24:47 -050012SRCREV = "756f70010779927dc0691e1e722ed433d5d295e1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Brad Bishop868407c2019-11-04 13:24:47 -050014PV = "0.13.8"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16S = "${WORKDIR}/git"
17
Brad Bishop23eaf032019-11-20 05:15:02 -050018PACKAGECONFIG ??= "instrumentation"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020PACKAGECONFIG:remove:mipsarch = "instrumentation"
21PACKAGECONFIG:remove:powerpc = "instrumentation"
22PACKAGECONFIG:remove:riscv32 = "instrumentation"
Brad Bishop23eaf032019-11-20 05:15:02 -050023
24PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
25
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026inherit autotools pkgconfig
27
28EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030do_configure:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031 (cd ${S}; ./autogen.sh; cd -)
32}