blob: 14d9942c0260bacd2bc476b4ce4912b553e7a1f9 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11inherit gnomebase gettext systemd gobject-introspection bash-completion
12
13DEPENDS = "glib-2.0 libgudev libxslt-native dbus"
14
15SRCREV ?= "a7bcf2036b34d5043dbc33fee7d98bae5859c4d3"
16
17# Patches 0001, 0002 will be in ModemManager > 1.18.6
18SRC_URI = " \
19 git://gitlab.freedesktop.org/mobile-broadband/ModemManager.git;protocol=https;branch=mm-1-18 \
20 file://0001-core-switch-bash-shell-scripts-to-use-bin-sh-for-use.patch \
21 file://0002-fcc-unlock-Make-scripts-POSIX-shell-compatible.patch \
22"
23
24S = "${WORKDIR}/git"
25
26# strict, permissive
27MODEMMANAGER_POLKIT_TYPE ??= "permissive"
28
29PACKAGECONFIG ??= "vala mbim qmi \
30 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
31"
32
33PACKAGECONFIG[at] = "-Dat_command_via_dbus=true"
34PACKAGECONFIG[systemd] = " \
35 -Dsystemdsystemunitdir=${systemd_unitdir}/system/, \
36 -Dsystemdsystemunitdir=no -Dsystemd_journal=false -Dsystemd_suspend_resume=false \
37"
38PACKAGECONFIG[polkit] = "-Dpolkit=${MODEMMANAGER_POLKIT_TYPE},-Dpolkit=no,polkit"
39# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
40PACKAGECONFIG[mbim] = "-Dmbim=true,-Dmbim=false -Dplugin_dell=disabled -Dplugin_foxconn=disabled,libmbim"
41# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
42PACKAGECONFIG[qmi] = "-Dqmi=true,-Dqmi=false,libqmi"
43PACKAGECONFIG[qrtr] = "-Dqrtr=true,-Dqrtr=false,libqrtr-glib"
44PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false"
45
46inherit ${@bb.utils.contains('PACKAGECONFIG', 'vala', 'vala', '', d)}
47
48EXTRA_OEMESON = " \
49 -Dudevdir=${nonarch_base_libdir}/udev \
50 -Dqrtr=false \
51"
52
53FILES:${PN} += " \
54 ${datadir}/icons \
55 ${datadir}/polkit-1 \
56 ${datadir}/dbus-1 \
57 ${datadir}/ModemManager \
58 ${libdir}/ModemManager \
59 ${systemd_unitdir}/system \
60"
61
62SYSTEMD_SERVICE:${PN} = "ModemManager.service"