blob: f7a98fb61e8fa81857e945e95d3cb9ae2f294018 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "A tool for transfer files to/from any OBEX enabled device"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only & PD & LGPL-2.1-only"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003LIC_FILES_CHKSUM = "file://LGPL-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
4 file://GPL-2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://License.txt;md5=fcbddc3c1debed80dd80da2d3e5f0dc1 \
6 "
7
8DEPENDS += "openobex obexftp-native"
9SRC_URI = "http://downloads.sourceforge.net/openobex/${BP}-Source.tar.gz \
10 file://Remove_some_printf_in_obexftpd.patch \
11 file://0001-apps-CMakeLists.txt-Explicitly-link-libbfb-and-libmu.patch \
12 file://make_fuse_swig_optional.patch \
13"
14SRC_URI[md5sum] = "157a9d1b2ed220203f7084db906de73c"
15SRC_URI[sha256sum] = "d40fb48e0a0eea997b3e582774b29f793919a625d54b87182e31a3f3d1c989a3"
16
17inherit cmake pkgconfig
18
Brad Bishop316dfdd2018-06-25 12:45:53 -040019OECMAKE_GENERATOR = "Unix Makefiles"
20
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021PACKAGECONFIG ?= ""
22# fuse support will need meta-filesystems layer
23PACKAGECONFIG[fuse] = "-DENABLE_FUSE=ON,-DENABLE_FUSE=OFF,fuse"
24PACKAGECONFIG[swig] = "-DENABLE_SWIG=ON,-DENABLE_SWIG=OFF,swig"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026DEPENDS:remove:class-native = "fuse-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027
28S = "${WORKDIR}/${BP}-Source"
29
30EXTRA_OECMAKE += "-DCMAKE_SKIP_RPATH=ON \
31 -DENABLE_PERL=OFF -DENABLE_PYTHON=OFF \
32 -DENABLE_RUBY=OFF -DENABLE_TCL=OFF \
33"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035do_compile:class-native () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036 oe_runmake crctable
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:class-native () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040 install -D -m 0755 ${B}/bfb/crctable ${D}${bindir}/crctable
41}
42
43BBCLASSEXTEND = "native"