blob: 487681c92de82276a27f20a3dedd03d0861fd4ca [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "D-Bus wrapper in C++ for dbus"
2HOMEPAGE = "https://dbus-cxx.github.io/"
3BUGTRACKER = "https://github.com/libsigcplusplus/libsigcplusplus/issues"
4SECTION = "base"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=4cf0188f02184e1e84b9586ac53c3f83"
7
8SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master;protocol=https \
9 file://0001-Include-typeinfo-for-typeid.patch \
10"
11SRC_URI:append:libc-musl = "file://fix_build_musl.patch"
12SRCREV = "73532d6a5faae9c721c2cc9535b8ef32d4d18264"
13
14DEPENDS = "\
15 dbus \
16 libsigc++-3 \
17"
18
19RDEPENDS:${PN} = "\
20 dbus \
21 libsigc++-3 \
22"
23
24S = "${WORKDIR}/git"
25
26inherit pkgconfig cmake
27
28OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"