blob: c88d392970e09a8bb746a9810228ab91f73907b7 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & MIT & CC0-1.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=74a614eac8b2657a4b8e6607421a0883"
10
11inherit meson pkgconfig bash-completion systemd
12
13SRCREV = "dd58d43458943d20ff063850670bf54a5242c9c5"
14SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https \
15 file://0001-util-Correct-path-to-iniparser.h.patch \
16 file://0001-meson-Use-pkg-config-to-detect-iniparser.patch"
17
18UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)"
19
20DEPENDS = "kmod udev json-c keyutils iniparser"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF += "-Ddestructive=enabled"
25
26PACKAGECONFIG ??= "tests ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
27PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
28PACKAGECONFIG[tests] = "-Dtest=enabled, -Dtest=disabled,"
29PACKAGECONFIG[docs] = "-Ddocs=enabled -Dasciidoctor=enabled,-Ddocs=disabled -Dasciidoctor=disabled, asciidoc-native"
30
31SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
32SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service daxdev-reconfigure@.service"
33SYSTEMD_AUTO_ENABLE:${PN} = "disable"
34
35FILES:${PN} += "${datadir}/daxctl/daxctl.conf "