blob: 39f0b4c5607f109eca023a0572753a229a8909b9 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "sdbus-c++"
2DESCRIPTION = "High-level C++ D-Bus library designed to provide easy-to-use yet powerful API in modern C++"
3
4SECTION = "libs"
5
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "LGPL-2.1-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00007LIC_FILES_CHKSUM = "file://COPYING;md5=1803fa9c2c3ce8cb06b4861d75310742"
8
9inherit cmake pkgconfig systemd ptest
10
11PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \
12 ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
13PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap"
14PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
15PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF,googletest gmock"
16
17DEPENDS += "expat"
18
19SRCREV = "65782bbf435d91e5eb6af9ddab110df406a824a9"
20
21SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master"
22SRC_URI += "file://run-ptest"
23
Andrew Geissler9aee5002022-03-30 16:27:02 +000024EXTRA_OECMAKE = "-DBUILD_CODE_GEN=OFF \
Andrew Geissler595f6302022-01-24 19:11:47 +000025 -DBUILD_DOC=ON \
26 -DBUILD_DOXYGEN_DOC=OFF"
27
28S = "${WORKDIR}/git"
29
30do_install:append() {
31 if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
32 rm -rf ${D}${sysconfdir}/dbus-1
33 fi
34}
35
36PTEST_PATH = "${libdir}/${BPN}/tests"
37FILES:${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/"
38FILES:${PN}-dev += "${bindir}/sdbus-c++-xml2cpp"