blob: 8ff5ddd175866c25e03ca2e69c6ede4cabb31aaa [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "BSD-3-Clause | GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=80c467906eb826339c7f09e61808ed23"
5
6S = "${WORKDIR}/git"
7SRCREV = "2936ecd060c299157ac880650ba2c9fd94d27bb1"
8SRC_URI = "git://github.com/smuellerDD/libkcapi.git;branch=master;protocol=https \
9 file://0001-kcapi-kernel-if-Adjust-for-musl-msghdr-struct-compat.patch \
10 "
11
12inherit autotools
13
14PACKAGECONFIG ??= ""
15PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
16PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
17PACKAGECONFIG[hasher_only] = "--enable-kcapi-hasher --disable-lib-kdf --disable-lib-sym --disable-lib-aead --disable-lib-rng,,,"
18
19do_install:append() {
20 # bindir contains testapp and apps. However it is always created, even
21 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
22 rmdir --ignore-fail-on-non-empty ${D}${bindir}
23
24 # Remove the generated binary checksum files
25 rm -f ${D}${bindir}/.*.hmac
26 rm -f ${D}${libdir}/.*.hmac
27}
28
29CPPFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare"
30
31BBCLASSEXTEND = "native"