blob: 3218ba652a8ebffea1b2d9c2b027041c7cb793fb [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
2DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
3from the CPUID instruction, and also determines the exact model of CPU(s). \
4It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
5UMC, NexGen, Rise, and SiS CPUs"
6HOMEPAGE="http://www.etallen.com/cpuid.html"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9
10SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
11 "
12SRC_URI[sha256sum] = "230772bb88c44732e68a42d2eff43bcff46d893bf4ea6e04151d4cb6e8c88e2f"
13
14COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
15
16inherit perlnative
17
18# The install rule from the Makefile has hardcoded paths, so we duplicate
19# the actions to accommodate different paths.
20do_install () {
21 install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid
22 install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir}
23}