blob: 2f0d8a3400aa8b69a747064f46abb74a46533d6a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Debug Malloc Library"
5
6DESCRIPTION = "The debug memory allocation or dmalloc library has been \
7designed as a drop in replacement for the system's malloc, realloc, \
8calloc, free and other memory management routines while providing \
9powerful debugging facilities configurable at runtime. These facilities \
10include such things as memory-leak tracking, fence-post write detection, \
11file/line number reporting, and general logging of statistics."
12
13HOMEPAGE = "http://dmalloc.com/"
14LICENSE = "CC-BY-SA-3.0"
15
16LIC_FILES_CHKSUM = "file://dmalloc.c;beginline=4;endline=17;md5=83d13664f87f1f1a3b6b2b6f6eba85aa"
17
18SECTION = "libs"
19
20SRC_URI = "http://dmalloc.com/releases/dmalloc-${PV}.tgz \
21 file://02-Makefile.in.patch \
22 file://03-threads.patch \
23 file://13-fix-ldflags-in-makefile.patch \
24 file://configure-pagesize-HACK.patch \
25 file://100-use-xtools.patch \
26 file://130-mips.patch \
27 file://150-use_DESTDIR.patch \
28 file://0001-undefined-strdup-macro.patch \
29"
30
31SRC_URI[md5sum] = "f92e5606c23a8092f3d5694e8d1c932e"
32SRC_URI[sha256sum] = "d3be5c6eec24950cb3bd67dbfbcdf036f1278fae5fd78655ef8cdf9e911e428a"
33
34ARM_INSTRUCTION_SET = "arm"
35
36inherit autotools
37
38EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
39EXTRA_OECONF += "--enable-threads --enable-cxx --enable-shlib"