blob: 29937e26d0c6d6e6252ed87815f29b5b90209553 [file] [log] [blame]
Andrew Geissler4b7c1152020-11-30 19:55:29 -06001SUMMARY = "Heap memory profiler for Linux"
2DESCRIPTION = "Heaptrack traces all memory allocations and annotates these \
3events with stack traces. Dedicated analysis tools then allow you to interpret \
4the heap memory profile to find hotspots to reduce memory, leaks, allocation \
5hotspots and temporary allocations"
6HOMEPAGE = "https://phabricator.kde.org/source/heaptrack/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "LGPL-2.1-only"
Andrew Geissler4b7c1152020-11-30 19:55:29 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
9
10DEPENDS = "zlib boost libunwind elfutils"
11
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/KDE/heaptrack.git;protocol=https;branch=master \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060013 file://0001-libheaptrack-Replace-__pid_t-with-pid_t.patch \
14 file://0002-heaptrack_inject-Include-dlfcn.h-for-dlopen-dlclose.patch \
15 file://0003-heaptrack_preload-Make-noexcept-attribute-conditiona.patch \
16 file://0004-backtrace-Always-include-stdint.h.patch \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070017 file://0001-track-Check-for-unw_set_caching_policy-before-using.patch \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060018 "
19
20SRCREV = "bc9e3744bcc47de978673d1e382f4125a1ab5fa8"
21
22S = "${WORKDIR}/git"
23
24inherit cmake
25
26EXTRA_OECMAKE += "-DHEAPTRACK_BUILD_GUI=OFF"
27
28# libunwind is not yet ported to RISCV
Patrick Williams213cb262021-08-07 19:21:33 -050029COMPATIBLE_HOST:riscv32 = "null"
30COMPATIBLE_HOST:riscv64 = "null"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060031
32BBCLASSEXTEND = "native nativesdk"