blob: 0f6bbb4d545e56b5d81a23a23be8a9a1af63bca3 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A console-based network monitoring utility"
5DESCRIPTION = "IPTraf-ng is a console-based network monitoring utility. IPTraf gathers \
6data like TCP connection packet and byte counts, interface statistics \
7and activity indicators, TCP/UDP traffic breakdowns, and LAN station \
8packet and byte counts. IPTraf-ng features include an IP traffic monitor \
9which shows TCP flag information, packet and byte counts, ICMP \
10details, OSPF packet types, and oversized IP packet warnings; \
11interface statistics showing IP, TCP, UDP, ICMP, non-IP and other IP \
12packet counts, IP checksum errors, interface activity and packet size \
13counts; a TCP and UDP service monitor showing counts of incoming and \
14outgoing packets for common TCP and UDP application ports, a LAN \
15statistics module that discovers active hosts and displays statistics \
16about their activity; TCP, UDP and other protocol display filters so \
17you can view just the traffic you want; logging; support for Ethernet, \
18FDDI, ISDN, SLIP, PPP, and loopback interfaces; and utilization of the \
19built-in raw socket interface of the Linux kernel, so it can be used \
20on a wide variety of supported network cards."
21
22HOMEPAGE = "https://fedorahosted.org/iptraf-ng/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000023LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000024LIC_FILES_CHKSUM = "file://LICENSE;md5=e2b3850593b899b1a17594ed4cc4c731"
25DEPENDS = "ncurses"
26
27SRC_URI = "https://src.fedoraproject.org/repo/pkgs/iptraf-ng/v${PV}.tar.gz/sha512/44d36fc92cdbf379f62cb63638663c3ee610225b9c28d60ee55e62e358f398a6b0db281129327b3472e45fb553ee3dd605af09c129f2233f8839ae3dbd799384/v${PV}.tar.gz \
28 file://iptraf-ng-tmpfiles.conf \
29 file://ncurses-config.patch \
30 file://0001-make-Make-CC-weak-assignment.patch \
31 "
32SRC_URI[sha256sum] = "9f5cef584065420dea1ba32c86126aede1fa9bd25b0f8362b0f9fd9754f00870"
33
34inherit pkgconfig
35
36CFLAGS += "-D_GNU_SOURCE"
37
38do_compile() {
39 oe_runmake
40}
41
42do_install() {
43 oe_runmake DESTDIR=${D} install
44 install -D -m 0644 -p ${S}/iptraf-ng-logrotate.conf ${D}${sysconfdir}/logrotate.d/iptraf-ng
45 install -Dm 0644 ${WORKDIR}/iptraf-ng-tmpfiles.conf ${D}${libdir}/tmpfiles.d/iptraf-ng-tmpfiles.conf
46}
47
48FILES:${PN} += "${libdir}/tmpfiles.d"
49PROVIDES = "iptraf"
50RPROVIDES:${PN} += "iptraf"
51RREPLACES:${PN} += "iptraf"
52RCONFLICTS:${PN} += "iptraf"
53