blob: 169500f6b4de0ae7a1808a563aa16c12963bb35e [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
Brad Bishop00ab2372019-10-14 11:06:18 -040010HOMEPAGE = "https://gitlab.com/ymorin/kconfig-frontends"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "GPL-2.0-only"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
Brad Bishop996bc452019-12-02 13:05:15 -050014DEPENDS += "ncurses flex-native gperf-native bison-native"
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += "python3 bash"
Brad Bishop00ab2372019-10-14 11:06:18 -040016SRC_URI = "git://gitlab.com/ymorin/kconfig-frontends.git;protocol=https;branch=4.11.x \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://0001-Makefile-ensure-frontends-exits-before-writing-into-.patch \
18 file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
19
20SRCREV = "f22fce3a308be1c7790ebefc6bbedb33c5f7c86a"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig
Patrick Williams213cb262021-08-07 19:21:33 -050025do_configure:prepend () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026 mkdir -p ${S}/scripts/.autostuff/m4
27}
28
Patrick Williams213cb262021-08-07 19:21:33 -050029do_install:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030 ln -s kconfig-conf ${D}${bindir}/conf
31 ln -s kconfig-mconf ${D}${bindir}/mconf
32}
33
34EXTRA_OECONF += "--disable-gconf --disable-qconf"
35
36# Some packages have the version preceeding the .so instead properly
37# versioned .so.<version>, so we need to reorder and repackage.
38SOLIBS = "-${@d.getVar('PV')[:-2]}.so"
39FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
40
41BBCLASSEXTEND = "native"