blob: 11f6a1ad19fde80b56d388e3435b9f7b33f00dfe [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Perl module to manipulate and access gzip files"
2DESCRIPTION = "This package contains the gzip.pm module with friends. \
3The module implements perlio layer for gzip."
4
5HOMEPAGE = "https://metacpan.org/pod/PerlIO::gzip"
6SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008LIC_FILES_CHKSUM = "file://README;beginline=55;endline=61;md5=bc3da2dec1fbea59ac91172c5e0eb837"
9
10DEPENDS += "perl"
11
12SRC_URI = "https://cpan.metacpan.org/authors/id/N/NW/NWCLARK/PerlIO-gzip-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "0393eae5d0b23df6cf40ed44af7d711c"
15SRC_URI[sha256sum] = "4848679a3f201e3f3b0c5f6f9526e602af52923ffa471a2a3657db786bd3bdc5"
16
17S = "${WORKDIR}/PerlIO-gzip-${PV}"
18
19EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
20
21inherit cpan
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN} += "perl perl-module-perlio"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
30BBCLASSEXTEND = "native nativesdk"