blob: 1ec205f8b81b891dbeb523836227b9d678e9d2bd [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "This script upgrades packages automatically and unattended."
2DESCRIPTION = "The purpose of unattended-upgrades is to keep the computer current with the latest security (and other) updates automatically."
3HOMEPAGE = "https://wiki.debian.org/UnattendedUpgrades"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
6 file://debian/copyright;md5=62b5f2ac0ede901fb245eefbe54c181f"
7
8SRC_URI = "git://github.com/mvo5/unattended-upgrades.git;protocol=https;branch=master \
9 file://0001-unattended-upgrade-Remove-distro_info-usage-to-check.patch \
10 "
11
12SRCREV = "c6db6fad26a2b83ba301b52ff5dee98cef7558ca"
13
14S = "${WORKDIR}/git"
15
Andrew Geissler9aee5002022-03-30 16:27:02 +000016inherit setuptools3_legacy
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017
18DEPENDS += "apt intltool-native python3-distutils-extra-native"
19RDEPENDS:${PN} += "apt lsb-release python3-apt python3-core python3-datetime python3-email python3-fcntl python3-io python3-logging python3-stringold python3-syslog"
20
Andrew Geissler9aee5002022-03-30 16:27:02 +000021do_configure:prepend () {
22 install -Dm 0644 ${S}/data/50unattended-upgrades.Debian ${S}/data/50unattended-upgrades
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023}
24
25do_install:append () {
26 # fix bad installation path's
27 mv -v ${D}/usr/usr/share/* ${D}/usr/share/
28 rm -r ${D}/usr/usr
29}
30
Andrew Geissler9aee5002022-03-30 16:27:02 +000031FILES:${PN} = "${bindir} ${exec_prefix}/etc ${libdir} ${datadir} ${nonarch_libdir}"