blob: 5e991d309957e54009cf0ed84ab4c8d02c4d66a4 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Open-source software for volunteer computing"
5DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \
6source software platform which supports distributed computing, primarily in \
7the form of volunteer computing and desktop Grid computing. It is well \
8suited for problems which are often described as trivially parallel. BOINC \
9is the underlying software used by projects such as SETI@home, Einstein@Home, \
10ClimatePrediciton.net, the World Community Grid, and many other distributed \
11computing projects. \
12This package installs the BOINC client software, which will allow your \
13computer to participate in one or more BOINC projects, using your spare \
14computer time to search for cures for diseases, model protein folding, study \
15global warming, discover sources of gravitational waves, and many other types \
16of scientific and mathematical research."
17
18HOMEPAGE = "http://boinc.berkeley.edu/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000019LICENSE = "LGPL-2.0-or-later & GPL-3.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
21 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6"
22SECTION = "applications"
23DEPENDS = "curl \
24 jpeg \
25 openssl \
26 sqlite3 \
Andrew Geissler9aee5002022-03-30 16:27:02 +000027 virtual/egl \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000028 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \
30 nettle \
31"
32SRCREV = "b49adfb118211e11c719766c0d71e7bdfe7f3363"
33BRANCH = "client_release/7/7.18"
34SRC_URI = "git://github.com/BOINC/boinc;protocol=https;branch=${BRANCH} \
35 file://boinc-AM_CONDITIONAL.patch \
36 file://gtk-configure.patch \
37 file://4563.patch \
38"
39
40inherit gettext autotools pkgconfig features_check systemd
41
42REQUIRED_DISTRO_FEATURES += "opengl"
43
44S = "${WORKDIR}/git"
45
46EXTRA_OECONF += "\
47 --enable-libraries \
48 --enable-unicode \
49 --enable-shared \
50 --enable-dynamic-client-linkage \
51 --enable-client \
52 --disable-server \
53 --disable-static \
54 --disable-manager \
55 --with-ssl=${STAGING_EXECPREFIXDIR} \
56 --without-wxdir \
57 --without-x \
58 --with-boinc-platform=${TARGET_SYS} \
59 ac_cv_c_undeclared_builtin_options='none' \
60"
61export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config"
62
63do_configure:prepend () {
64 if [ "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0" ]
65 then
66 export GTK2_CFLAGS=""
67 export GTK2_LIBS=""
68 fi
69}
70
71do_compile:prepend () {
72 # Disable rpaths
73 sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/libtool
74 sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/libtool
75 sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/libtool
76}
77
78do_install:append() {
79 if [ -e ${D}${nonarch_libdir}/systemd/system/boinc-client.service ]; then
80 install -d ${D}${systemd_system_unitdir}
81 mv \
82 ${D}${nonarch_libdir}/systemd/system/boinc-client.service \
83 ${D}${systemd_system_unitdir}/boinc-client.service
84 rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir}/systemd/system \
85 ${D}${nonarch_libdir}/systemd \
86 ${D}${nonarch_libdir}
87 fi
88}
89
90SYSTEMD_SERVICE:${PN} = "boinc-client.service"
91
92FILES:${PN} += "${libdir}/systemd"