blob: dd97796f46f123958679d5515573d5acbd425278 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Collects and summarises system performance statistics"
2DESCRIPTION = "collectd is a daemon which collects system performance statistics periodically and provides mechanisms to store the values in a variety of ways, for example in RRD files."
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only & MIT"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=1bd21f19f7f0c61a7be8ecacb0e28854"
5
6DEPENDS = "rrdtool curl libpcap libxml2 yajl libgcrypt libtool lvm2"
7
8SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \
9 file://collectd.init \
10 file://collectd.service \
11 file://no-gcrypt-badpath.patch \
12 file://0001-fix-to-build-with-glibc-2.25.patch \
13 file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \
14 file://0005-Disable-new-gcc8-warnings.patch \
15 file://0006-libcollectdclient-Fix-string-overflow-errors.patch \
16 file://0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch \
17 "
Andrew Geisslerd688a012020-09-18 13:36:00 -050018SRC_URI[md5sum] = "2b23a65960bc323d065234776a542e04"
19SRC_URI[sha256sum] = "5bae043042c19c31f77eb8464e56a01a5454e0b39fa07cf7ad0f1bfc9c3a09d6"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21inherit autotools python3native update-rc.d pkgconfig systemd
22
Patrick Williams213cb262021-08-07 19:21:33 -050023SYSTEMD_SERVICE:${PN} = "collectd.service"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25# Floatingpoint layout, architecture dependent
26# 'nothing', 'endianflip' or 'intswap'
27FPLAYOUT ?= "--with-fp-layout=nothing"
28
29PACKAGECONFIG ??= ""
30PACKAGECONFIG[openjdk] = "--with-java=${STAGING_DIR_TARGET}${libdir}/jvm,--without-java,openjdk-7"
31PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp --with-libnetsnmp=no,net-snmp"
32PACKAGECONFIG[libmemcached] = "--with-libmemcached,--without-libmemcached,libmemcached"
33PACKAGECONFIG[iptables] = "--enable-iptables,--disable-iptables,iptables"
34PACKAGECONFIG[postgresql] = "--enable-postgresql --with-libpq=yes, \
35 --disable-postgresql --with-libpq=no,postgresql"
36PACKAGECONFIG[mysql] = "--enable-mysql --with-libmysql=yes, \
37 --disable-mysql --with-libmysql=no,mysql5"
38PACKAGECONFIG[dbi] = "--enable-dbi,--disable-dbi,libdbi"
39PACKAGECONFIG[modbus] = "--enable-modbus,--disable-modbus,libmodbus"
40PACKAGECONFIG[libowcapi] = "--with-libowcapi,--without-libowcapi,owfs"
41PACKAGECONFIG[sensors] = "--enable-sensors --with-libsensors=yes, \
42 --disable-sensors --with-libsensors=no,lmsensors"
43PACKAGECONFIG[amqp] = "--enable-amqp --with-librabbitmq=yes, \
44 --disable-amqp --with-librabbitmq=no,rabbitmq-c"
45# protobuf-c, libvirt that are currently only available in meta-virtualization layer
46PACKAGECONFIG[pinba] = "--enable-pinba,--disable-pinba,protobuf-c-native protobuf-c"
47PACKAGECONFIG[libvirt] = "--enable-virt,--disable-virt,libvirt"
48PACKAGECONFIG[libesmtp] = "--with-libesmtp,--without-libesmtp,libesmtp"
49PACKAGECONFIG[libmnl] = "--with-libmnl,--without-libmnl,libmnl"
50PACKAGECONFIG[libatasmart] = "--with-libatasmart,--without-libatasmart,libatasmart"
51PACKAGECONFIG[ldap] = "--enable-openldap --with-libldap,--disable-openldap --without-libldap, openldap"
Andrew Geisslera2681d92020-10-16 10:17:07 -050052PACKAGECONFIG[rrdtool] = "--enable-rrdtool,--disable-rrdtool,rrdtool"
53PACKAGECONFIG[rrdcached] = "--enable-rrdcached,--disable-rrdcached,rrdcached"
Andrew Geissler82c905d2020-04-13 13:39:40 -050054
55EXTRA_OECONF = " \
56 ${FPLAYOUT} \
57 --disable-perl --with-libperl=no --with-perl-bindings=no \
58 --with-libgcrypt=${STAGING_BINDIR_CROSS}/libgcrypt-config \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060059 --disable-notify_desktop --disable-werror \
Andrew Geissler82c905d2020-04-13 13:39:40 -050060"
61
Patrick Williams213cb262021-08-07 19:21:33 -050062do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050063 install -d ${D}${sysconfdir}/init.d
64 install -m 0755 ${WORKDIR}/collectd.init ${D}${sysconfdir}/init.d/collectd
65 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/collectd
66 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/collectd
67 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/collectd
68 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/collectd
69 install -Dm 0640 ${B}/src/collectd.conf ${D}${sysconfdir}/collectd.conf
70 # Fix configuration file to allow collectd to start up
71 sed -i 's!^#FQDNLookup[ \t]*true!FQDNLookup false!g' ${D}${sysconfdir}/collectd.conf
72
Andrew Geissler595f6302022-01-24 19:11:47 +000073 rmdir ${D}${localstatedir}/run ${D}${localstatedir}/log
74 rmdir --ignore-fail-on-non-empty ${D}${localstatedir}
Andrew Geissler82c905d2020-04-13 13:39:40 -050075
76 # Install systemd unit files
77 install -d ${D}${systemd_unitdir}/system
78 install -m 0644 ${WORKDIR}/collectd.service ${D}${systemd_unitdir}/system
79 sed -i -e 's,@SBINDIR@,${sbindir},g' \
80 ${D}${systemd_unitdir}/system/collectd.service
81}
82
Patrick Williams213cb262021-08-07 19:21:33 -050083CONFFILES:${PN} = "${sysconfdir}/collectd.conf"
Andrew Geissler82c905d2020-04-13 13:39:40 -050084
85INITSCRIPT_NAME = "collectd"
86INITSCRIPT_PARAMS = "defaults"
87
88# threshold.so load.so are also provided by gegl
89# disk.so is also provided by libgphoto2-camlibs
90PRIVATE_LIBS = "threshold.so load.so disk.so"