blob: 0b1e7e6088073192357b667f5b1b271c2150cd9f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "display dialog boxes from shell scripts"
2DESCRIPTION = "Dialog lets you to present a variety of questions \
3or display messages using dialog boxes from a shell \
4script (or any scripting language)."
5HOMEPAGE = "http://invisible-island.net/dialog/"
6SECTION = "console/utils"
7DEPENDS = "ncurses"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "LGPL-2.1-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
10
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070011SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz"
12SRC_URI[sha256sum] = "ae478fe7d5fca82bcf4b51684641e07d2ee68489d319710fe1e81f41a197bd66"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14# hardcoded here for use in dialog-static recipe
15S = "${WORKDIR}/dialog-${PV}"
16
17inherit autotools-brokensep pkgconfig
18
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
20
21PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
22
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023EXTRA_OECONF = "--with-ncurses \
24 --disable-rpath-hack"
25
26do_configure() {
27 gnu-configize --force
28 sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
29 sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
30 oe_runconf
31}