blob: 7674785437f0f09a263fcf0cb8d43ec9689d818e [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Duktape embeddable Javascript engine"
2DESCRIPTION = "Duktape is an embeddable Javascript engine, with a focus on portability and compact footprint."
3HOMEPAGE = "https://duktape.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b7825df97b52f926fc71300f7880408"
6
7SRC_URI = "https://duktape.org/duktape-${PV}.tar.xz"
8SRC_URI[sha256sum] = "90f8d2fa8b5567c6899830ddef2c03f3c27960b11aca222fa17aa7ac613c2890"
9
10EXTRA_OEMAKE = "INSTALL_PREFIX='${prefix}' DESTDIR='${D}' LIBDIR='/${baselib}'"
11
12do_compile () {
13 oe_runmake -f Makefile.sharedlibrary INSTALL_PREFIX="${prefix}" DESTDIR="${D}"
14}
15
16do_install () {
17 oe_runmake -f Makefile.sharedlibrary INSTALL_PREFIX="${prefix}" DESTDIR="${D}" install
18 # libduktaped is identical to libduktape but has an hard-coded -g build flags, remove it
19 rm -f ${D}${libdir}/libduktaped.so*
20}