blob: a83a11c684c1678c4effb47f439abf292bdb3915 [file] [log] [blame]
Andrew Geissler32b11992021-03-31 13:37:05 -05001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "libleak detects memory leak by hooking memory functions (e.g. malloc) by LD_PRELOAD"
5HOMEPAGE = "https://github.com/WuBingzheng/libleak"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "GPL-2.0-only"
Andrew Geissler32b11992021-03-31 13:37:05 -05007LIC_FILES_CHKSUM = "file://README.md;beginline=18;endline=21;md5=de4f705f12cdedbe452b2c3524572b03"
8
9DEPENDS += "libbacktrace"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "gitsm://github.com/WuBingzheng/libleak;protocol=https;branch=master \
Andrew Geissler32b11992021-03-31 13:37:05 -050012 file://0001-respect-environment-variables.patch \
13 "
14
15PV = "1.0+git${SRCPV}"
16SRCREV = "ea2bb608ae25701692269a37d39d77e966b887ac"
17
18S = "${WORKDIR}/git"
19
20do_configure () {
21 :
22}
23
24do_compile () {
25 oe_runmake
26}
27
28do_install () {
29 install -Dm 0755 ${B}/libleak.so ${D}${libdir}/libleak.so
30}
31
32FILES_SOLIBSDEV = ""
33
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN} += "${libdir}/libleak.so"
Andrew Geissler32b11992021-03-31 13:37:05 -050035
36# libunwind does not support RISCV yet
Patrick Williams213cb262021-08-07 19:21:33 -050037COMPATIBLE_HOST:riscv64 = "null"
38COMPATIBLE_HOST:riscv32 = "null"