blob: ce3606d777a8912d17887b005411283b04d7d34b [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "An IPC library for high performance servers"
2DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
3It provides high performance logging, tracing, ipc, and poll."
4
5HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
6SECTION = "libs"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
9
10inherit autotools pkgconfig
11
12SRCREV = "758044bed5f615c90818aa5431d00303288888e5"
13SRC_URI = "git://github.com/ClusterLabs/${BPN}.git;branch=main;protocol=https \
14 "
15S = "${WORKDIR}/git"
16
17DEPENDS += "libxml2"
18
19CFLAGS += "-pthread -D_REENTRANT"
20
21do_configure:prepend() {
22 ( cd ${S}
23 ${S}/autogen.sh )
24}
25
26BBCLASSEXTEND = "native"