blob: 8f41769e02c97b52cd352adb91d2257dea6ad7d6 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "YANG data modeling language library"
2DESCRIPTION = "libyang is a YANG data modelling language parser and toolkit written (and providing API) in C."
3HOMEPAGE = "https://github.com/CESNET/libyang"
4SECTION = "libs"
5LICENSE = "BSD-3-Clause"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=f3916d7d8d42a6508d0ea418cfff10ad"
8
9SRCREV = "a0cc89516ab5eca84d01c85309f320a94752a64c"
10
11SRC_URI = "git://github.com/CESNET/libyang.git;branch=master;protocol=https \
12 file://libyang-add-stdint-h.patch \
13 file://run-ptest \
14 "
15
16S = "${WORKDIR}/git"
17
18# Due to valgrind not supported on these arches:
19COMPATIBLE_HOST:riscv32 = "null"
20COMPATIBLE_HOST:armv5 = "null"
21COMPATIBLE_HOST:riscv64 = "null"
22
23# Main dependencies
24inherit cmake pkgconfig lib_package binconfig-disabled ptest
25DEPENDS = "libpcre2"
26DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'cmocka', '', d)}"
27BINCONFIG = "${bindir}/pcre2-config"
28
29# Ptest dependencies
30RDEPENDS:${PN}-ptest += "valgrind"
31
32EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
33EXTRA_OECMAKE += " ${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_TESTS=ON', '', d)}"
34
35do_install_ptest () {
36 cp -fR ${B}/tests/ ${D}${PTEST_PATH}/
37}
38