blob: 7359c125449379f2cd4ec0613e93174030abca42 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The RARP daemon."
2DESCRIPTION = "RARP (Reverse Address Resolution Protocol) is a protocol which \
3allows individual devices on an IP network to get their own IP addresses from \
4the RARP server. Some machines (e.g. SPARC boxes) use this protocol instead \
5of e.g. DHCP to query their IP addresses during network bootup. \
6Linux kernels up to 2.2 used to provide a kernel daemon for this service, \
7but since 2.3 kernels it is served by this userland daemon. \
8You should install rarpd if you want to set up a RARP server on your \
9network."
10SECTION = "System Environment/Daemons"
11
12SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/${BPN}/${BP}.tar.gz/be2a88f8ccddf2a40ac484cb3294fedc/${BP}.tar.gz"
13SRC_URI[md5sum] = "be2a88f8ccddf2a40ac484cb3294fedc"
14SRC_URI[sha256sum] = "4d6145d435a5d8b567b9798620f57f9b0a464078a1deba267958f168fbe776e6"
15
16SRC_URI += "file://0001-rarpd.8-add-man-file.patch \
17 file://0002-Makefile-modify-compile-parameters.patch \
18 file://0003-rarpd.c-bug-fix.patch \
19 file://0004-rarpd.init-add-new-init-file.patch \
20 file://0005-ethernet.c-remove-it.patch \
21 file://ethers.sample \
22 file://rarpd.service \
23"
24
Andrew Geissler9aee5002022-03-30 16:27:02 +000025LICENSE = "GPL-2.0-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026LIC_FILES_CHKSUM = "file://rarpd.c;md5=199b20b172ea93121bc613a9c77b6931"
27
28S = "${WORKDIR}/${BPN}"
29
30EXTRA_OEMAKE = "-e MAKEFLAGS="
31
32do_install() {
33 install -d ${D}${sysconfdir}/init.d
34 install -d ${D}${sbindir}
35 install -d ${D}${mandir}/man8
36 install -m 755 rarpd.init ${D}${sysconfdir}/init.d/rarpd
37 install -m 755 rarpd ${D}${sbindir}/rarpd
38 install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8
39 install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers
40
Brad Bishop316dfdd2018-06-25 12:45:53 -040041 install -d ${D}${systemd_unitdir}/system
42 install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/
Patrick Williamsb48b7b42016-08-17 15:04:38 -050043}
44
Brad Bishop316dfdd2018-06-25 12:45:53 -040045inherit systemd
Patrick Williamsb48b7b42016-08-17 15:04:38 -050046
47SYSTEMD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050048SYSTEMD_SERVICE:${PN} = "rarpd.service"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050049SYSTEMD_AUTO_ENABLE = "disable"
50
Patrick Williams213cb262021-08-07 19:21:33 -050051RDEPENDS:${PN} += "bash"