blob: 575443f0e53b793ad4bf124d3f60a0ffb6097f34 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "C++ client for Redis based on hiredis"
2HOMEPAGE = "https://github.com/sewenew/redis-plus-plus"
3SECTION = "libs"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
8 file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch \
9 "
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRCREV = "389ffdf9e72035ea2096b03cda7f4a6809ae6363"
11
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16DEPENDS += "hiredis"
17
18RDEPENDS:${PN} += "hiredis"
19
20FILES_SOLIBSDEV = ""
21FILES:${PN} += " ${libdir}/libredis++.so*"
22
23INSANE_SKIP:${PN} += "dev-so"