blob: 4181da732fdfc7b21854ce9ae7a4320577125e30 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work"
2DESCRIPTION = "Sysdig is open source, system-level exploration: capture \
3system state and activity from a running Linux instance, then save, \
4filter and analyze."
5HOMEPAGE = "http://www.sysdig.org/"
6LICENSE = "Apache-2.0 & (MIT | GPL-2.0-only)"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44"
8
9inherit cmake pkgconfig
10
11#OECMAKE_GENERATOR = "Unix Makefiles"
12JIT ?= "jit"
13JIT:mipsarchn32 = ""
14JIT:mipsarchn64 = ""
15JIT:riscv64 = ""
16JIT:riscv32 = ""
17JIT:powerpc = ""
18JIT:powerpc64le = ""
19JIT:powerpc64 = ""
20
21DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp \
22 tbb jq openssl elfutils protobuf protobuf-native jq-native valijson"
23RDEPENDS:${PN} = "bash"
24
25SRC_URI = "git://github.com/draios/sysdig.git;branch=dev;protocol=https;name=sysdig \
26 git://github.com/falcosecurity/libs;protocol=https;branch=master;name=falco;subdir=git/falcosecurity-libs \
27 file://0001-cmake-Pass-PROBE_NAME-via-CFLAGS.patch \
28 "
29SRCREV_sysdig = "4fb6288275f567f63515df0ff0a6518043ecfa9b"
30SRCREV_falco= "caa0e4d0044fdaaebab086592a97f0c7f32aeaa9"
31
32S = "${WORKDIR}/git"
33
34EXTRA_OECMAKE = "\
35 -DBUILD_DRIVER=OFF \
36 -DMINIMAL_BUILD=ON \
37 -DUSE_BUNDLED_DEPS=OFF \
38 -DCREATE_TEST_TARGETS=OFF \
39 -DDIR_ETC=${sysconfdir} \
40 -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \
41 -DFALCOSECURITY_LIBS_SOURCE_DIR=${S}/falcosecurity-libs \
42 -DVALIJSON_INCLUDE=${STAGING_INCDIR}/valijson \
43"
44
45#CMAKE_VERBOSE = "VERBOSE=1"
46
47FILES:${PN} += " \
48 ${DIR_ETC}/* \
49 ${datadir}/zsh/* \
50 ${prefix}/src/* \
51"
52# Use getaddrinfo_a is a GNU extension in libsinsp
53# It should be fixed in sysdig, until then disable
54# on musl
55# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
56COMPATIBLE_HOST:libc-musl = "null"
57COMPATIBLE_HOST:mips = "null"
58COMPATIBLE_HOST:riscv64 = "null"
59COMPATIBLE_HOST:riscv32 = "null"
60COMPATIBLE_HOST:powerpc = "null"
61COMPATIBLE_HOST:powerpc64le = "null"