blob: 38704f8b93300c80ffea429197481889d564c2b2 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A library to help create and query binary XML blobs"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
4
5SRC_URI = "git://github.com/hughsie/libxmlb.git;branch=main;protocol=https \
6 file://run-ptest \
7 "
8SRCREV = "4782df2cec808f71762aa9f69c11759b4e127b61"
9S = "${WORKDIR}/git"
10
11inherit gobject-introspection gtk-doc meson ptest-gnome lib_package
12
13PACKAGECONFIG ??= "\
14 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
15"
16PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
17
18GTKDOC_MESON_OPTION = "gtkdoc"
19
20FILES:${PN}-bin += "${libexecdir}/*"