blob: 2005afa2fd0d5a3a558142eb1157045738bc35a8 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# SPDX-FileCopyrightText: Huawei Inc.
2#
3# SPDX-License-Identifier: MIT
4
5HOMEPAGE = "https://lvgl.io/"
6DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI"
7SUMMARY = "Light and Versatile Graphics Library"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
10
11SRC_URI = "gitsm://github.com/lvgl/lvgl;destsuffix=${S};protocol=https;nobranch=1"
12SRCREV = "d38eb1e689fa5a64c25e677275172d9c8a4ab2f0"
13
14REQUIRED_DISTRO_FEATURES = "wayland"
15
16inherit cmake
17inherit features_check
18
Andrew Geissler9aee5002022-03-30 16:27:02 +000019EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${BASELIB}"
Andrew Geissler595f6302022-01-24 19:11:47 +000020S = "${WORKDIR}/${PN}-${PV}"
21
22LVGL_CONFIG_LV_MEM_CUSTOM ?= "0"
23
24# Upstream does not support a default configuration
25# but propose a default "disabled" template, which is used as reference
26# More configuration can be done using external configuration variables
27do_configure:prepend() {
28 [ -r "${S}/lv_conf.h" ] \
29 || sed -e 's|#if 0 .*Set it to "1" to enable .*|#if 1 // Enabled|g' \
30 -e "s|\(#define LV_MEM_CUSTOM .*\)0|\1${LVGL_CONFIG_LV_MEM_CUSTOM}|g" \
31 < "${S}/lv_conf_template.h" > "${S}/lv_conf.h"
32}
33
34FILES:${PN}-dev += "\
35 ${includedir}/${PN}/ \
36 ${includedir}/${PN}/lvgl/ \
37 "