blob: 18e36380521e2ab8a0bd9d04ba4307650d176f6b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Shows and sets processor power related values"
2DESCRIPTION = "cpupower is a collection of tools to examine and tune power \
3saving related features of your processor."
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005DEPENDS = "pciutils gettext-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006PROVIDES = "virtual/cpupower"
7
Brad Bishopc342db32019-05-15 21:57:59 -04008inherit kernelsrc kernel-arch bash-completion
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10do_populate_lic[depends] += "virtual/kernel:do_patch"
11
12EXTRA_OEMAKE = "-C ${S}/tools/power/cpupower O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
13
14do_configure[depends] += "virtual/kernel:do_shared_workdir"
15
16do_compile() {
17 oe_runmake
18}
19
20do_install() {
21 oe_runmake DESTDIR=${D} install
22 # Do not ship headers
23 rm -rf ${D}${includedir}
24 chown -R root:root ${D}
25}
26
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} = "bash"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030
Patrick Williams213cb262021-08-07 19:21:33 -050031python do_package:prepend() {
Brad Bishop19323692019-04-05 15:28:33 -040032 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033}
34
35B = "${WORKDIR}/${BPN}-${PV}"