blob: a1c4cc9eb932bcdda55b7adad70d81bfebba2e22 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "TOMOYO Linux tools"
2DESCRIPTION = "TOMOYO Linux is a Mandatory Access Control (MAC) implementation \
3for Linux that can be used to increase the security of a system, while also \
4being useful purely as a system analysis tool."
5HOMEPAGE = "http://tomoyo.sourceforge.jp/"
6SECTION = "System Environment/Kernel"
7
8SRC_URI = "http://jaist.dl.sourceforge.jp/tomoyo/53357/${BP}-20170102.tar.gz"
9SRC_URI[md5sum] = "888804d58742452fe213a68f7eadd0ad"
10SRC_URI[sha256sum] = "00fedfac5e514321250bbe69eaccc732c8a8158596f77a785c2e3ae9f9968283"
11
12S = "${WORKDIR}/${BPN}"
13
Andrew Geissler9aee5002022-03-30 16:27:02 +000014LICENSE = "GPL-2.0-only"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015LIC_FILES_CHKSUM = "file://COPYING.tomoyo;md5=751419260aa954499f7abaabaa882bbe"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017FILES:${PN} += "${libdir}/tomoyo"
18FILES:${PN}-dbg += "${libdir}/tomoyo/.debug"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019
20DEPENDS = "linux-libc-headers ncurses"
21
22EXTRA_OEMAKE = "-e USRLIBDIR=${libdir}"
23
24do_compile () {
25 oe_runmake 'CC=${CC}'
26}
27
28do_install() {
29 oe_runmake install INSTALLDIR=${D}
30}