blob: 35540b3b8f07188ceb85e1c3448fad5560722430 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Monitor for system resources and process activity"
2DESCRIPTION = "Atop is an ASCII full-screen performance monitor for Linux that \
3is capable of reporting the activity of all processes (even if processes have \
4finished during the interval), daily logging of system and process activity for \
5long-term analysis, highlighting overloaded system resources by using colors, \
6etc. At regular intervals, it shows system-level activity related to the CPU, \
7memory, swap, disks (including LVM) and network layers, and for every process \
8(and thread) it shows e.g. the CPU utilization, memory growth, disk \
9utilization, priority, username, state, and exit code."
10HOMEPAGE = "http://www.atoptool.nl"
11SECTION = "console/utils"
12
Andrew Geissler9aee5002022-03-30 16:27:02 +000013LICENSE = "GPL-2.0-only"
Brad Bishop19323692019-04-05 15:28:33 -040014LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
15
16DEPENDS = "ncurses zlib"
17
18SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \
20 file://fix-permissions.patch \
21 file://sysvinit-implement-status.patch \
22 file://0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch \
23 "
24SRC_URI[md5sum] = "1077da884ed94f2bc3c81ac3ab970436"
25SRC_URI[sha256sum] = "be1c010a77086b7d98376fce96514afcd73c3f20a8d1fe01520899ff69a73d69"
26
27do_compile() {
28 oe_runmake all
29}
30
31do_install() {
32 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
33 make DESTDIR=${D} VERS=${PV} SYSDPATH=${systemd_system_unitdir} \
34 PMPATHD=${systemd_unitdir}/system-sleep systemdinstall
35 install -d ${D}${sysconfdir}/tmpfiles.d
36 install -m 644 ${WORKDIR}/volatiles.atop.conf ${D}${sysconfdir}/tmpfiles.d/atop.conf
37 rm -f ${D}${systemd_system_unitdir}/atopacct.service
38 else
39 make DESTDIR=${D} VERS=${PV} sysvinstall
40 install -d ${D}${sysconfdir}/default/volatiles
41 install -m 644 ${WORKDIR}/volatiles.99_atop ${D}${sysconfdir}/default/volatiles/99_atop
42 rm -f ${D}${sysconfdir}/init.d/atopacct
43 fi
44
Andrew Geissler595f6302022-01-24 19:11:47 +000045 # /var/log/atop will be created in runtime
46 rm -rf ${D}${localstatedir}/log
47 rmdir --ignore-fail-on-non-empty ${D}${localstatedir}
48
Brad Bishop19323692019-04-05 15:28:33 -040049 # remove atopacct related files
50 rm -rf ${D}${sbindir} ${D}${mandir}/man8
51}
52
53inherit systemd
54
Patrick Williams213cb262021-08-07 19:21:33 -050055SYSTEMD_SERVICE:${PN} = "atop.service atopgpu.service"
Brad Bishop19323692019-04-05 15:28:33 -040056SYSTEMD_AUTO_ENABLE = "disable"
57
Patrick Williams213cb262021-08-07 19:21:33 -050058FILES:${PN} += "${systemd_unitdir}/system-sleep"
Brad Bishop19323692019-04-05 15:28:33 -040059
Patrick Williams213cb262021-08-07 19:21:33 -050060RDEPENDS:${PN} = "procps"