blob: 0936b1ae191133fbc739158a15731ff25a74a470 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "copy-paste for the Linux console"
2DESCRIPTION = "Consolation is a daemon that provides copy-paste and scrolling \
3support to the Linux console. It is based on the libinput library and \
4supports all pointer devices and settings provided by this library. Similar \
5software include gpm and jamd."
6HOMEPAGE = "https://salsa.debian.org/consolation-team/consolation"
7SECTION = "console/utils"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "GPL-2.0-or-later"
Andrew Geisslerd688a012020-09-18 13:36:00 -05009LIC_FILES_CHKSUM = "file://LICENSE;md5=73ca626e1d9048abfc7d599370650827"
10
11DEPENDS = " \
12 libevdev \
13 libinput \
14 udev \
15"
16
Andrew Geissler595f6302022-01-24 19:11:47 +000017SRC_URI = "git://salsa.debian.org/consolation-team/consolation.git;branch=master"
Andrew Geisslerd688a012020-09-18 13:36:00 -050018SRCREV = "4581eaece6e49fa2b687efbdbe23b2de452e7902"
19
20S = "${WORKDIR}/git"
21
22inherit autotools pkgconfig systemd
23
Patrick Williams213cb262021-08-07 19:21:33 -050024do_install:append() {
Andrew Geisslerd688a012020-09-18 13:36:00 -050025 install -d ${D}${systemd_system_unitdir}
26 install -m 644 ${B}/consolation.service ${D}${systemd_system_unitdir}
27}
28
Patrick Williams213cb262021-08-07 19:21:33 -050029SYSTEMD_SERVICE:${PN} = "consolation.service"