blob: 3cc870481f76357f7be5c3937505a2d1f44da383 [file] [log] [blame]
Brad Bishopdec060e2019-09-23 08:01:31 -04001SUMMARY = "dhex is a hex editor that includes a diff mode"
2SECTION = "console/utils"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05003HOMEPAGE = "http://www.dettus.net/dhex/"
Brad Bishopdec060e2019-09-23 08:01:31 -04004
5DEPENDS = "ncurses"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-or-later"
Brad Bishopdec060e2019-09-23 08:01:31 -04008LIC_FILES_CHKSUM = "file://README.txt;beginline=229;endline=241;md5=6f252a421b65bcecf624382ba3c899da"
9
10SRC_URI = "http://www.dettus.net/dhex/dhex_0.69.tar.gz"
11SRC_URI[md5sum] = "64d557437fe110c19f23ed3e9bbcdd54"
12SRC_URI[sha256sum] = "52730bcd1cf16bd4dae0de42531be9a4057535ec61ca38c0804eb8246ea6c41b"
13
14S = "${WORKDIR}/dhex_${PV}"
15
16EXTRA_OEMAKE += "'CC=${CC}' 'LDFLAGS=${LDFLAGS}' 'CPPFLAGS=${CPPFLAGS}'"
17
18do_compile() {
19 oe_runmake
20}
21
22do_install() {
23 install -m 0755 -d ${D}${bindir}
24 install -m 0755 ${S}/dhex ${D}${bindir}/
25}