blob: 4fe70982a5ae7fbfaa79bb858b81f6e615426eca [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Interactive process viewer"
2HOMEPAGE = "https://htop.dev"
3SECTION = "console/utils"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00005LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "git://github.com/htop-dev/htop.git;branch=main;protocol=https \
10 file://0001-Use-pkg-config.patch \
11"
12SRCREV = "d73783d6dbec4a8d9d20d744bf2b5e6a7073aa46"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= " \
19 unicode \
20 affinity \
21 delayacct \
22"
23PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
24PACKAGECONFIG[affinity] = "--enable-affinity,--disable-affinity,,,,hwloc"
25PACKAGECONFIG[unwind] = "--enable-unwind,--disable-unwind,libunwind"
26PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc,,,affinity"
27PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
28PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
29PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver"
30PACKAGECONFIG[capabilities] = "--enable-capabilities,--disable-capabilities,libcap"
31PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
32PACKAGECONFIG[sensors] = "--enable-sensors,--disable-sensors,lmsensors,lmsensors-libsensors"
33
34FILES:${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg"
35
36RDEPENDS:${PN} += "ncurses-terminfo-base"