blob: 6148e7cb082441f1092b30a4514d500d2fab7853 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "the Apache Kafka C/C++ client library"
2DESCRIPTION = "librdkafka is a C library implementation of the Apache Kafka protocol, \
3 providing Producer, Consumer and Admin clients."
4HOMEPAGE = "https://github.com/edenhill/librdkafka"
5SECTION = "libs"
6LICENSE = "BSD-2-Clause"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=2be8675acbfdac48935e73897af5f646"
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010SRC_URI = "git://github.com/edenhill/librdkafka;protocol=https;branch=master \
11 file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR.patch \
12 "
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRCREV = "063a9ae7a65cebdf1cc128da9815c05f91a2a996"
14
15DEPENDS = "zlib openssl zstd"
16
17inherit cmake
18
19S = "${WORKDIR}/git"
20
21FILES:${PN} += "${datadir}"
22
23EXTRA_OECMAKE += "-DRDKAFKA_BUILD_EXAMPLES=OFF -DRDKAFKA_BUILD_TESTS=OFF"