blob: d84041ce636f4f1b476dea8ae545f645f1839764 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Locking devices library"
2SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "LGPL-2.1-only"
Brad Bishop19323692019-04-05 15:28:33 -04004LIC_FILES_CHKSUM="file://LICENSE;md5=d8045f3b8f929c1cb29a1e3fd737b499"
5
6PE = "1"
7SRC_URI = "http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/l/lockdev/lockdev_${PV}.orig.tar.gz \
8 http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/l/lockdev/lockdev_${PV}-1.6.diff.gz;name=debianpatch \
9 file://cross_compile.patch \
10 file://build.patch \
11 "
12SRC_URI[md5sum] = "64b9c1b87b125fc348e892e24625524a"
13SRC_URI[sha256sum] = "ccae635d7ac3fdd50897eceb250872b3d9a191d298f213e7f0c836910d869f82"
14SRC_URI[debianpatch.md5sum] = "5ef6267c42fca9145e0af006ccb6aff7"
15SRC_URI[debianpatch.sha256sum] = "a5405c6ee5e97e45eeb1c81330a7e9f444a58bda5e6771fa30007516c115007e"
16
17inherit lib_package perlnative
Brad Bishop19323692019-04-05 15:28:33 -040018
19CFLAGS += " -D__GNU_LIBRARY__"
20
21TARGET_CC_ARCH += "${LDFLAGS}"
22
Brad Bishope42b3e32020-01-15 22:08:42 -050023EXTRA_OEMAKE = "basedir=${D}${prefix} baselib=${baselib} LD='${CC}' LD='${CC}'"
Brad Bishop19323692019-04-05 15:28:33 -040024do_compile() {
Brad Bishope42b3e32020-01-15 22:08:42 -050025 oe_runmake shared static
Brad Bishop19323692019-04-05 15:28:33 -040026}
27do_install() {
Brad Bishope42b3e32020-01-15 22:08:42 -050028 oe_runmake DESTDIR=${D} install
Brad Bishop19323692019-04-05 15:28:33 -040029}