blob: 249e2421c4f703ef58ed4e89053088dcedd8baca [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "https://mcelog.org/"
6SECTION = "System Environment/Base"
7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http;;branch=master \
9 file://run-ptest \
10"
11
12SRCREV = "4146c9296a0cbd26f1c5e411cb44877f350053bd"
13
14LICENSE = "GPL-2.0-only"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
16
17S = "${WORKDIR}/git"
18
19inherit autotools-brokensep ptest
20
21COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
22
23do_install:append() {
24 install -d ${D}${sysconfdir}/cron.hourly
25 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
26 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
27}
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}
31 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
32 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
33}
34
35RDEPENDS:${PN}-ptest += "make bash mce-inject"