blob: ba268de0a597d033b05b1bebffc6bb4c22bcfc88 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Mail processing program"
2DESCRIPTION = "Procmail can be used to create mail-servers, mailing lists, sort your\
3incoming mail into separate folders/files (real convenient when subscribing\
4to one or more mailing lists or for prioritising your mail), preprocess\
5your mail, start any programs upon mail arrival (e.g. to generate different\
6chimes on your workstation for different types of mail) or selectively\
7forward certain incoming mail automatically to someone."
8HOMEPAGE = "http://www.procmail.org/"
9SECTION = "Applications/System"
10
11SRC_URI = "http://www.ring.gr.jp/archives/net/mail/${BPN}/${BP}.tar.gz \
12 file://from-debian-to-fix-compile-errors.patch \
13 file://from-debian-to-modify-parameters.patch \
14 file://from-debian-to-fix-man-file.patch \
15 file://man-file-mailstat.1-from-debian.patch"
16SRC_URI[md5sum] = "1678ea99b973eb77eda4ecf6acae53f1"
17SRC_URI[sha256sum] = "087c75b34dd33d8b9df5afe9e42801c9395f4bf373a784d9bc97153b0062e117"
18
Andrew Geissler9aee5002022-03-30 16:27:02 +000019LICENSE = "GPL-2.0-only & Artistic-1.0"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020LIC_FILES_CHKSUM = "file://COPYING;md5=a71e50e197a992c862379e576e669757 \
21 file://Artistic;md5=505e00d03c3428cde21b17b2a386590e"
22
23DEPENDS = "libnet"
24inherit autotools-brokensep
25do_configure() {
26 find examples -type f | xargs chmod 644
27 export CC="${BUILD_CC}"
28 export LD="${BUILD_LD}"
29 export CFLAGS="${BUILD_CFLAGS}"
30 export AR="${BUILD_AR}"
31 export AS="${BUILD_AS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032 make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${BUILD_LDFLAGS}" autoconf.h
Patrick Williamsb48b7b42016-08-17 15:04:38 -050033}
34
35do_compile() {
Brad Bishop7f28bc52017-12-03 23:42:40 -050036 oe_runmake -i TARGET_CFLAGS="$TARGET_CFLAGS -Wno-comments -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${LDFLAGS}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050037}
38
39do_install() {
40 install -d ${D}${bindir}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041 install -d ${D}${mandir}/man1
42 install -d ${D}${mandir}/man5
Patrick Williamsb48b7b42016-08-17 15:04:38 -050043 oe_runmake -i BASENAME=${D}/usr MANDIR=${D}${mandir} install
44 install -m 0644 debian/mailstat.1 ${D}${mandir}/man1
45}