blob: 867a621d1a09e0a1082ccf2b15802ceb830d849d [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Terminal-based tool for monitoring the progress of data through a pipeline"
2HOMEPAGE = "http://www.ivarch.com/programs/pv.shtml"
3
4LICENSE = "Artistic-2.0"
5LIC_FILES_CHKSUM = "file://doc/COPYING;md5=9c50db2589ee3ef10a9b7b2e50ce1d02"
6
7SRC_URI = "https://www.ivarch.com/programs/sources/${BP}.tar.bz2 \
8 file://run-ptest \
9"
10SRC_URI[sha256sum] = "e831951eff0718fba9b1ef286128773b9d0e723e1fbfae88d5a3188814fdc603"
11
12UPSTREAM_CHECK_URI = "http://www.ivarch.com/programs/pv.shtml"
13UPSTREAM_CHECK_REGEX = "pv-(?P<pver>\d+(\.\d+)+).tar.bz2"
14
15inherit autotools ptest
16
17LDEMULATION:mipsarchn32 = "${@bb.utils.contains('TUNE_FEATURES', 'bigendian', 'elf32btsmipn32', 'elf32ltsmipn32', d)}"
18export LDEMULATION
19
20RDEPENDS:${PN}-ptest = "coreutils"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests
25 cp -r ${S}/autoconf/scripts/run-test.sh ${D}${PTEST_PATH}
26 # sed -i -e 's@\$SRCDIR/@./@g' ${D}${PTEST_PATH}/run-ptest
27}