blob: 23cafa7e48675ca6edfb312535e076f7e6f91dfe [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "A feature rich Remote Desktop Application written in GTK+"
2HOMEPAGE = "https://remmina.org"
3SECTION = "Support"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only & OpenSSL"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769"
6
7DEPENDS = " \
8 glib-2.0-native \
9 openssl \
10 freerdp \
11 gtk+3 \
12 gdk-pixbuf \
13 atk \
14 libgcrypt \
15 libsodium \
16 libssh \
17 vte \
18 json-glib \
19 libsoup-2.4 \
20 libvncserver \
21 libsecret \
22 libxkbfile \
23"
24
25DEPENDS:append:libc-musl = " libexecinfo"
26LDFLAGS:append:libc-musl = " -lexecinfo"
27
28SRCREV = "ffa6a7ef9c6be7951bac23d14df148098fd2d3fa"
29SRC_URI = "git://gitlab.com/Remmina/Remmina;protocol=https;branch=master"
30S = "${WORKDIR}/git"
31
32inherit cmake features_check mime mime-xdg gtk-icon-cache pkgconfig
33REQUIRED_DISTRO_FEATURES = "x11"
34
35EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF -DHAVE_LIBAPPINDICATOR=OFF"
36
37PACKAGECONFIG[spice] = "-DWITH_SPICE=ON, -DWITH_SPICE=OFF, spice spice-protocol"
38# Switch on gtk support in avahi recipe if you want to enable avahi support
39PACKAGECONFIG[avahi] = "-DWITH_AVAHI=ON, -DWITH_AVAHI=OFF, avahi"
40
41RDEPENDS:${PN} = "bash"
42
43FILES:${PN}+= " \
44 ${datadir}/metainfo \
45 ${datadir}/mime \
46"