blob: b40fa5255cef8c55e7dc7d89f85735b1b42e2c98 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "USB hub per-port power control"
2HOMEPAGE = "https://github.com/mvp/uhubctl"
3BUGTRACKER = "https://github.com/mvp/uhubctl/issues"
4DEPENDS = "libusb1"
5
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
William A. Kennington III49e95662021-09-15 16:19:36 -07009SRCREV = "014b55ac5d1d7fb46a8f1eefe9fc3b87ea65a75f"
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/mvp/${BPN};branch=master;protocol=https"
Brad Bishop26bdd442019-08-16 17:08:17 -040011S = "${WORKDIR}/git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
13# uhubctl gets its program version from "git describe". As we use the source
14# archive do reduce download size replace the call with our hardcoded version.
Patrick Williams213cb262021-08-07 19:21:33 -050015do_configure:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile
17}
18
19do_install () {
20 oe_runmake install DESTDIR=${D}
21}