blob: 55a7354820de1f5a8ba205f81e053c71fed4b1ef [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
4
5DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib"
6
7SRC_URI = "git://gitlab.freedesktop.org/upower/upower.git;protocol=https;branch=master"
8SRCREV = "0f6cc0a10be22d7ddd684e1cd851e4364a440494"
9S = "${WORKDIR}/git"
10
11UPSTREAM_CHECK_GITTAGREGEX = "UPOWER_(?P<pver>\d+(\_\d+)+)"
12
13inherit autotools pkgconfig gtk-doc gettext gobject-introspection systemd
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
16PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
17PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
18 --without-systemdutildir --without-systemdsystemunitdir,systemd"
19
20EXTRA_OECONF = " --with-backend=linux"
21
22SYSTEMD_SERVICE:${PN} = "upower.service"
23# don't start on boot by default - dbus does that on demand
24SYSTEMD_AUTO_ENABLE = "disable"
25
26do_configure:prepend() {
27 touch ${S}/ABOUT-NLS
28 mkdir -p ${S}/build-aux
29 touch ${S}/build-aux/config.rpath
30 sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
31 sed -i -e 's: doc : :g' ${S}/Makefile.am
32}
33
34RDEPENDS:${PN} += "dbus"
35RRECOMMENDS:${PN} += "pm-utils"
36FILES:${PN} += "${datadir}/dbus-1/ \
37 ${base_libdir}/udev/* \
38"