blob: 7ea1aa8f3d00ec8ce444d5bb25d2472c9d4b35b5 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4AUTHOR = "Sam Stephenson & bats-core organization"
5HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8
9SRC_URI = "git://github.com/bats-core/bats-core.git;branch=master;protocol=https"
10# v1.4.1
11SRCREV = "210acf3a8ed318ddedad3137c15451739beba7d4"
12
13S = "${WORKDIR}/git"
14
15do_configure:prepend() {
16 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats
17 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-file
18 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-test
19}
20
21do_install() {
22 # Just a bunch of bash scripts to install
23 ${S}/install.sh ${D}${prefix} ${baselib}
24}
25
26RDEPENDS:${PN} = "bash"
27FILES:${PN} += "${libdir}/bats-core/*"
28
29PACKAGECONFIG ??= "pretty"
30PACKAGECONFIG[pretty] = ",,,ncurses"