blob: ef1b6e537ba6f11e49ef77effd554970de8260b0 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit."
2HOMEPAGE = "http://cxxtest.com/"
3SECTION = "devel"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "LGPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00005LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
Brad Bishop19323692019-04-05 15:28:33 -04006
Andrew Geissler595f6302022-01-24 19:11:47 +00007SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/${BP}.tar.gz"
Brad Bishop19323692019-04-05 15:28:33 -04008SRC_URI[md5sum] = "c3cc3355e2ac64e34c215f28e44cfcec"
9SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f4895cf7d8"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011inherit setuptools3
Brad Bishop19323692019-04-05 15:28:33 -040012
Andrew Geissler9aee5002022-03-30 16:27:02 +000013PIP_INSTALL_DIST_PATH = "${B}/python/python3/dist"
14
Andrew Geissler595f6302022-01-24 19:11:47 +000015SETUPTOOLS_SETUP_PATH = "${S}/python"
Brad Bishop19323692019-04-05 15:28:33 -040016
Patrick Williams213cb262021-08-07 19:21:33 -050017do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040018 install -d ${D}${includedir}
Andrew Geissler595f6302022-01-24 19:11:47 +000019 cp -a ${S}/cxxtest/ ${D}${includedir}
20 # Fix the interpretter as otherwise this points to the build host python
Brad Bishop19323692019-04-05 15:28:33 -040021 sed '1c\
Andrew Geissler595f6302022-01-24 19:11:47 +000022#!/usr/bin/env python3' -i ${D}${bindir}/cxxtestgen
Brad Bishop19323692019-04-05 15:28:33 -040023}
24
25BBCLASSEXTEND = "native nativesdk"