blob: b40d52ab94f40a6eba8dae2d48e0057d62e9d8f5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Analyzes log files and sends noticeable events as email"
2DESCRIPTION = "\
3Logcheck is a simple utility which is designed to allow a system administrator \
4to view the log-files which are produced upon hosts under their control. \
5It does this by mailing summaries of the log-files to them, after first \
6filtering out "normal" entries. \
7Normal entries are entries which match one of the many included regular \
8expression files contain in the database."
9SECTION = "Applications/System"
10HOMEPAGE = "http://logcheck.org/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "GPL-2.0-only"
Brad Bishop19323692019-04-05 15:28:33 -040012LIC_FILES_CHKSUM = "file://LICENSE;md5=c93c0550bd3173f4504b2cbd8991e50b"
13
14SRC_URI = "${DEBIAN_MIRROR}/main/l/${BPN}/${BPN}_${PV}.tar.xz \
15 file://99_logcheck \
16"
Andrew Geissler69721092021-07-23 12:57:00 -040017SRC_URI[sha256sum] = "a2188ba549fff4412c82074b271884ff66d25f3fdb2a41916e817ce676855b29"
Brad Bishop19323692019-04-05 15:28:33 -040018
19S = "${WORKDIR}/${BPN}"
20
21inherit useradd
22
23USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050024USERADD_PARAM:${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \
Brad Bishop19323692019-04-05 15:28:33 -040025 -s /bin/false -c 'logcheck account' ${BPN}"
Patrick Williams213cb262021-08-07 19:21:33 -050026GROUPADD_PARAM:${PN} = "-r ${BPN}"
Brad Bishop19323692019-04-05 15:28:33 -040027
28do_install() {
29 # Fix QA Issue
30 sed -i '/install -d $(DESTDIR)\/var\/lock\/logcheck/s/^/#/' Makefile
31
32 # "make install" do not install the manpages. Install them manually.
33 install -m 755 -d ${D}${mandir}/man1
34 install -m 755 -d ${D}${mandir}/man8
35 install -m 644 docs/logcheck-test.1 ${D}${mandir}/man1/
36 install -m 644 docs/logtail.8 ${D}${mandir}/man8/
37 install -m 644 docs/logtail2.8 ${D}${mandir}/man8/
38
39 install -m 755 -d ${D}${sysconfdir}/cron.d
40 install -m 644 debian/logcheck.cron.d ${D}${sysconfdir}/cron.d/logcheck
41 install -m 755 -d ${D}/var/lib/logcheck
42
43 oe_runmake install DESTDIR=${D}
44
45 # install header.txt for generated mails
46 install -m 0644 ${S}/debian/header.txt ${D}${sysconfdir}/${BPN}
47
48 chown -R ${BPN}:${BPN} ${D}${localstatedir}/lib/${BPN}
49 chown -R root:${BPN} ${D}${sysconfdir}/${BPN}
50
51 # Don't install /var/lock when populating rootfs. Do it through volatile
52 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
53 install -d ${D}${sysconfdir}/default/volatiles
54 install -m 0644 ${WORKDIR}/99_logcheck ${D}${sysconfdir}/default/volatiles
55 fi
56 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
57 install -d ${D}${sysconfdir}/tmpfiles.d
58 echo "d /var/lock/logcheck 0755 logcheck logcheck -" \
59 > ${D}${sysconfdir}/tmpfiles.d/logcheck.conf
60 fi
61}
62
63VIRTUAL-RUNTIME_syslog ??= "rsyslog"
64
Patrick Williams213cb262021-08-07 19:21:33 -050065RDEPENDS:${PN} = "\
Brad Bishop19323692019-04-05 15:28:33 -040066 bash \
67 cronie \
68 debianutils-run-parts \
69 grep \
70 lockfile-progs \
71 mime-construct \
72 perl \
73 perl-module-file-basename \
74 perl-module-getopt-std \
75 perl-module-file-glob \
76 ${VIRTUAL-RUNTIME_syslog} \
77"
78
Patrick Williams213cb262021-08-07 19:21:33 -050079FILES:${PN} += "${datadir}/logtail"