blob: 4c9864094da81857ef249e4b6209d250134d0ad1 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \
2HTTP requests and responses. Major features including processing form \
3submissions, file uploads, reading and writing cookies, query string generation \
4and manipulation, and processing and preparing HTTP headers."
5HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod"
6SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "Artistic-2.0 | GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008
9LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb"
10
11SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz"
12
13SRC_URI[sha256sum] = "9608a044ae2e87cefae8e69b113e3828552ddaba0d596a02f9954c6ac17fa294"
14
15S = "${WORKDIR}/CGI-${PV}"
16
17inherit cpan ptest-perl
18
19RDEPENDS:${PN} += "\
20 libhtml-parser-perl \
21 perl-module-base \
22 perl-module-deprecate \
23 perl-module-if \
24"
25
26do_install:prepend() {
27 # requires "-T" (taint) command line option
28 rm -rf ${B}/t/push.t
29 rm -rf ${B}/t/utf8.t
30 # tests building of docs
31 rm -rf ${B}/t/compiles_pod.t
32}
33
34RDEPENDS:${PN}-ptest += " \
35 libtest-deep-perl \
36 libtest-warn-perl \
37 perl-module-bytes \
38 perl-module-file-find \
39 perl-module-filehandle \
40 perl-module-findbin \
41 perl-module-lib \
42 perl-module-perlio \
43 perl-module-perlio-scalar \
44 perl-module-test-more \
45 perl-module-utf8 \
46"
47
48RPROVIDES:${PN} += "perl-module-cgi"
49
50BBCLASSEXTEND = "native"