blob: 3f004bb2ecff8fcbae619fcf5941bb68b6928960 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Guess OpenSSL include path"
2SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LIC_FILES_CHKSUM = "file://LICENSE;md5=ea914cc2718e8d53bd7744d96e66c03c"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Guess-${PV}.tar.gz "
7
8SRC_URI[sha256sum] = "1c5033381819fdb4c9087dd291b90ec70e7810d31d57eade9b388eccfd70386d"
9
10DEPENDS += "openssl"
11
12RDEPENDS:${PN} = "\
13 perl-module-config \
14 perl-module-exporter \
15 perl-module-extutils-mm \
16 perl-module-extutils-mm-unix \
17 perl-module-file-spec \
18 perl-module-symbol \
19 perl-module-strict \
20 perl-module-warnings \
21"
22
23EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
24
25S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
26
27inherit cpan ptest-perl
28
29BBCLASSEXTEND = "native"
30
31# for backwards compatibility
32PROVIDES_${PN} += "libcrypt-openssl-guess"
33
34RDEPENDS:${PN}-ptest += "\
35 perl-module-test-more \
36"