blob: ff3f4d69445db3eb15618028ae293c2c505690b6 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build"
2DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \
3Makefile.PL file to drive distribution configuration, build, test and \
4installation. Traditionally, Build.PL uses Module::Build as the underlying \
5build system. This module provides a simple, lightweight, drop-in replacement. \
6Whereas Module::Build has over 6,700 lines of code; this module has less than \
7120, yet supports the features needed by most distributions."
8SECTION = "libs"
9
10HOMEPAGE = "http://search.cpan.org/~leont/Module-Build-Tiny/"
11
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013LIC_FILES_CHKSUM = "file://LICENSE;md5=57b8100f0b648cd37fbc3725fe3c111a"
14
15DEPENDS = "libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-Tiny-${PV}.tar.gz"
18SRC_URI[md5sum] = "2332c90c17454107fea3f2614e11a3a9"
19SRC_URI[sha256sum] = "7d580ff6ace0cbe555bf36b86dc8ea232581530cbeaaea09bccb57b55797f11c"
20
21S = "${WORKDIR}/Module-Build-Tiny-${PV}"
22
23inherit cpan_build
24
25do_install () {
26 cpan_build_do_install
27}
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} = " libextutils-config-perl \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030 libextutils-helpers-perl \
31 libextutils-installpaths-perl \
32 perl-module-xsloader \
33 perl-module-file-spec \
34 perl-module-io-handle \
35 perl-module-tap-harness-env \
36 perl-module-ipc-open3 \
37 perl-module-file-path \
38 perl-module-cpan \
39 perl-module-extutils-cbuilder \
40 perl-module-getopt-long \
41 perl-module-extutils-makemaker \
42 perl-module-exporter \
43 perl-module-carp \
44 perl-module-test-more \
45 perl-module-text-parsewords \
46 perl-module-load \
47 perl-module-file-temp \
48 perl-module-data-dumper \
49 perl-module-extutils-parsexs \
50 perl-module-pod-man \
51 perl-module-json-pp \
52"
53
54BBCLASSEXTEND = "native"